דף הבית » חדשות ועדכונים

אקספלורר 7, את הבאה בתור

9 ביולי 2011 | מאת רמי | 13 תגובות | תגיות: ,

בגרסה 3.2 ממשק הניהול של וורדפרס הפסיק לתמוך בדפדפן אינטרנט אקספלורר 6, ואנחנו מקבלים יותר ויותר רמזים המעידים כי בגרסה 3.3 ממשק הניהול של וורדפרס יפסיק לתמוך באינטרנט אקספלורר 7. הידד!

אינטרנט אקספלורר 7

אינטרנט אקספלורר 7

רמז מצד המפתחים

אם בעבר כל מה שקשור להפסקת התמיכה בדפדפנים ישנים היה בגדר רעיון שלא יתקבל על הדעת, או סתם נושא לדיון בקרב מפתחים שרצו לפרוק את זעמם על הדפדפן הישן, הפעם מדובר בהצהרת כוונות מצד אחד המפתחים המרכזיים של וורדפרס. Mark Jaquith צייץ בטוויטר ואמר כי האינטרנט אקספלורר 7 היא הבא בתור.

ציוץ בטוויטר על הפסקת התמיכה באקספלורר 7

ציוץ בטוויטר על הפסקת התמיכה באקספלורר 7

הרקע למהלך

המהלך נובע, ככל הנראה, מהרצון לשכתב את כל קבצי ה-CSS בממשק הניהול. לטענת המפתחים יש יותר מדי קבצי CSS המטפלים בעיצוב של המסכים השונים. מסתבר שקיימות הגדרות CSS רבות שהן מיותרות לחלוטין אבל כיוון שאין שום דרך לדעת מה מיותר ומה לא, הוחלט לשכתב מחדש את כל קבצי ה-CSS במבנה חדש ויעיל יותר.

במהלך הדיונים עלתה השאלה המתבקשת בנושא תאימות לדפדפנים, שכן נדרשות התאמות מיוחדות עבור דפדפנים ישנים. וורדפרס 3.2 אומנם זנחה את התמיכה באקספלורר 6, אך עדיין נדרשות התאמות מרובות לאקספלורר 7 ו-8. סיבה זו, כנראה, הוביל את המפתחים לשקול ברצינות רבה את הפסקת התמיכה באקספלורר 7 בוורדפרס 3.3.

וורדפרס ומיקרוסופט

כשחברת מיקרוסופט שמעה שוורדפרס תפסיק לתמוך באקספלורר 6, הוא בירכה את וורדפרס ומפתחיה. למיקרוסופט אינטרס מובהק להפסיק את השימוש בדפדפן הישן הזה שגורם לה רק כאב ראש ופוגע בתדמית החדשנית שלה. מספיק לציין את העובדה שהתמיכה בדפדפן הופסקה לפני עשור כדי להמחיש את הבעיה בשימוש בו.

מיקרוספט מעודדת את הפסקת השימוש בגרסאות ישנות של האקספלורר בגלל פרצות האבטחה המרובות בהם והעובדה שהם אינם תומכים בסטנדרטים מודרניים. מצד שני, עם נתעלם לרגע מההיבט הטכנולוגי ניווכח שככל שיותר אנשים משדרגים את המחשבים שלהם, ההכנסות של החברה ממכירת מערכות הפעלה שולחניות עולים. מה שמיקרוסופט שוכחים זה שרוב המשתמשים בדפדפנים ישנים באים ממדינות עניות באסיה, אפריקה ודרום-אמריקה. לאוכלוסיות אלה אין כסף פנוי לשדרוג המחשב או עדכון גרסה של מערכת מערכת ההפעלה (המגיעה עם דפדפן מעודכן).

אז מה דעתכם, ההחלטה של וורדפרס להפסיק לתמוך גם בדפדפן המזדקן אינטרנט אקספלורר 7 היא החלטה טובה ליהודים?

מאת רמי

אחראי על אתר וורדפרס בעברית ועל תרגום ושחרור גרסאות וורדפרס בעברית. מפתח ליבה, בכל גרסה החל מגרסה 2.8, מפתח מוביל בגרסה 4.4 ובגרסה 4.6. מספק שירותי פיתוח אתרים, פיתוח תוספי וורדפרס לסטרטאפים ופיתוח כלים למפתחי וורדפרס - GenerateWP.com.

13 תגובות »

  • צחי כותב :

    מעולה! אולי הבא הבא בתור זה 8?

  • רמי כותב :

    אני בספק, קצב הנטישה של דפדפנים ישנים נמוך מאוד. אבל בוא נישאר אופטימיים.

  • צחי כותב :

    אני אופטימי 🙂

  • ארז כותב :

    בהחלט מעולה, וורדפרס בשימוש דיי רחב אז אני בטוח שזה יגרום ללא מעט אנשים לשדרג.

  • איתן כותב :

    לדעתי זו יוזמה מבורכת מה גם שאקספלורר 8 נמצא בגרסת שידרוג חינמית באתר של מיקרוסופט וזמין למשתמשי XP ו WIN2000 בחינם.
    כלומר הסיבה של משתמשים בארצות עניות לא ממש תופסת.

  • כרמית כותב :

    אקספלורר 7 לא גרוע כמו 6 אבל כדאי לקדם את כולם. בקשר לארצות עניות אני חושבת כמו שאיתן אמר. הדפדפן זמין להורדה וגם אם הוא כבד מידי למערכות הפעלה ישנות יש את הדפדפן של גוגל שגם יכול לעזור ולדעתי גם לעבוד טוב במערכות הפעלה ישנות. אני לא יודעת כמה ישנים המחשבים בארצות עניות אבל אם הם ישנים מידי אפילו פלש לא יעבוד בהם וספק בכלל אם אתרים (עם כל הגרפיקה שיש היום) יעלו למסך בזמן סביר.
    יש גם את פרוייקט מחשב לכל ילד שמספקים חומרה ברמה סבירה למקומות האלה.

  • צחי כותב :

    @כרמית
    נכון אקפלורר 7 לא גרוע כמו 6 אבל הוא כל כך 10 שנים אחורה שזה לא מאפשר לנו המפתחים להתקדם וזה לא אומר ש-8 מקבל יחס מיוחד הדפדפנים האילו פשוט מעכבים את הרשת ברמה כזו שרק פלטפורמה סגורה כמו פלאש יכולה להתמודד.

  • מאור חזן כותב :

    הגיע הזמן. מבחינתי גירסה 8 לא כ"כ שונה מ-7. שיבטלו את התמיכה בשניהם מצידי.

  • מאור חזן כותב :

    אגב… דפדפן זה לא נקבה אלא זכר ולכן כותרת הפוסט צריכה להיות "אקספלורר 7, אתה הבא בתור" ולא "אקספלורר 7, את הבאה בתור".

  • מתי כותב :

    מאור, תוכנה היא נקבה. כך שהכותרת אפשרית…

    לגבי תוכן הכותרת, המדינות העניות אינן כלל שאלה משום שמדובר רק על הניהול, וככל הנראה מדוחות ההורדה והשימוש של וורדפרס מתברר שרוב המשתמשים המנהלים אתר וורדפרס – אינם זקוקים להתאמה לאקספלורר 7. ההחלטה, אם תתקבל תהיה דומה לשדרוג דרישות השרת לphp 5.2.4 שהתבסססה על דוחות שימוש.

  • כרם כותב :

    לא יודעת, אני חוששת שאי תמיכה בעקספלורר 7 עשויה להיות התעלמות מקהל גולשים שהוא עדיין עצום. יש יותר מידי טכנופובים בעולמנו שפשוט לא משדרגים את הדפדפנים האלה במשך שנים על גבי שנים. מגיע להם עדיין להצליח להכנס לאתר שיפעל להם לפחות חלקית (בסדר שהפינות לא יהיו עגולות זה נסלח)
    אולי כדאי שוורדפרס יתחילו להשתמש בCSS3PIE?
    css3pie.com

  • רמי כותב :

    שימו לב שהפסקת התמיכה בדפדפנים היא ברמת ה-BackEnd כלומר במערכת הניהול ולא ברמת ה-FrontEnd כך שהאתרים עצמם לא יפגעו, וכל מעצב יוכל להתאים את התבנית שלו לכל דפדפן שירצה.

  • כרם כותב :

    אה אוקי, אם זה ברמת מערכת הניהול אז זה נשמע לי הוגן לחלוטין:-) אנו בוני האתרים בהחלט יכולים לשרוד גם בלי עקספלורר 7 המזופת… או בלי עקספלורר בכלל (פיכס)
    תודה רמי!

הוסף תגובה !

נא לא לשאול שאלות שלא קשורות לפוסט, זהו לא פורום תמיכה. לבעיות אישיות ונושאים מורכבים אפשר ליצור איתי קשר.

תגיות HTML מורשות לשימוש:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>